Trouble with default zoom on Position Chart

I have define a default zoom level (-5), but it doesn’t seem to “stick” in the dashboard.

Hi Lars,

I am testing this out and will get back to you soon with a solution.


I’m guessing you’re seeing something like what I have here, where your block has a default zoom but is set to automatically calculate the center point based on the data that is returned.

In my screenshot, I’m experiencing the same problem you describe - but the reason this is happening is because my device query is either invalid or it is not returning any results (no data matching the query).

We revert the block to a default center / zoom in this scenario because we do not have enough information to paint the block the way you would like it: we are unable to calculate the default center.

So if you enter a valid query - or one that does indeed return data - do you still see the issue you described here?

I do have device data. Updating x and y attributes every minute. The locations for each device show up, I just need to manually zoom out every time to see all devices.

I see what you’re talking about now; it will take some time to resolve but we’re looking into it.

FYI the block does snap to the correct zoom after the first time the dashboard data refreshes - assuming you haven’t panned or zoomed the block before that.

@Lars_Andersson we deployed a fix for this yesterday; the block should now be honoring the position settings you define in the editor.

Thanks for bringing the bug to our attention and please let us know if you have any more questions or come across any other issues!