[Solved] Charts not displaying properly with aggregation=NONE


#1

I have a dashboard with a couple charts, one using aggregation=MEAN and one with aggregation=NONE. The one set to NONE appears to be missing data that I know exists, but when I change the aggregation to MEAN the data shows up. Here’s an example:

MEAN:

NONE:

Thoughts? I’m assuming it’s a bug since I haven’t seen this behavior before.


#2

Brian,

Thanks for reporting that! It is in fact a bug, an interaction with a new option we rolled out today on time series graphs, the ability to not connect data gaps on bucketed data. We just pushed out a fix, if you reload, the graph should now be displaying properly.


#3

Hi Michael

The new features are nice, however with relatively small graphs and more than 1 line, the dots make the lines very thick. So that even with line weight of 1, we see the equivalent of of a line weight of 2. Not a big deal when there is long period between points, but most of our stuff is sampled every 3 seconds so the points are always very close together. Could you make the DOT optional ?

small_chart

Thanks

T


#4

Ha, we had an internal debate about that very thing!

The reason we added the dots is specifically for the “don’t connect data gaps” feature - i.e., without dots, an isolated data point (with gaps on both sides) would be invisible. We talked about adding options about including the dots, or controlling the dot size, but we didn’t want to add un-needed complication. Seems like it is in fact needed complication. I will file a ticket to add options for this.


#5

Awesome thanks.

For small compressed charts, we tend to ignore gaps. Looking at short period trends.
Where as large charts the over longer periods dots are good :wink:

T