How to debug why SMS via Twilio is not working


#1

Hi

I use Twilio through some other software we have written so I do have active Twilio account/subaccounts.

I am trying to set up sending SMS via Twilio from a workflow for the first time.

I believe I have the Twilio Account SID and Twilio Auth Token set up correctly

These come from the Sub Account which holds the number we wish to use.

When sending a message via Twilio - there is no record of the message in Twilio logs and of course I don’t receive an SMS.

it’s not clear how to debug this.

I have tried both Send From SID, and Send from Number (the SID being the SID of the number not the subaccount)
I assume that is correct or you couldn’t pick a specific number to the send from.

Any suggestion pointers would be welcome.

Thanks

Tim


#2

I’m not a Twilio user, but the general idea of diagnosing this kind of problem is: try to use Twilio credentials in a local (not cloud) app and see if it works. This would allow you to distinguish whether the problem is on Twilio side or on Losant side.


#3

There are a couple errors that the Twilio node can throw due to misconfiguration, which (if they are happening) should show up in the debug panel of the workflow.

Have you tried using the SMS node? Were you able to successfully send to your phone number using that node? (That node is backed by the Twilio node, just using a Losant Twilio account).

If you drop your workflow id in here, I can take a look at the configuration myself, and see if there is anything that jumps out.


#4

Hi

Yes we can send via the standard SMS node.

There was nothing at all in the debug log when triggering the Twilio node, hence my question above.
In addition there was nothing in the twilio logs.

Workflow id is 585a33c3d5a5e1010098bf0b

There are parrallel SMS and twilio nodes. (The SMS works fine).

Thanks

Tim


#5

Agreed,

however there no logs of activity twilio or debug messages in losant, which would suggest a definite usability issue, within losant. Without an error of any sort I can’t be sure that a twilio messages was sent even if it had been working.

We recently had outbound email blacklisted because of a bounce, but there was no notification, so it took a swhile to work out emails weren’t being sent. (The absence of fault notifcation of logging hides problems).

T


#6

It looks like the phone number in the Twilio node is invalid (I think it is missing a digit).

Currently, the behavior of that node when it is run is to discard any invalid phone number entries and not error - the theory being that it is better to send to the valid phone numbers and continue on than to not send to any numbers at all.

But you raise a good point, especially in the case of there only being a single phone number and the node ends up doing nothing - it is not at all obvious what is going on.

I’m going to file a ticket about making that better - how would you feel about having an optional config param on the node which places the “results” of the twilio node on the workflow payload? One entry per phone number, with success or an error message of some kind?


#7

Yep that was it. Trying to work on too many things and making mistakes ;-(
The invalid phone number was failing silently,

Now that I know what the problem was I can keep an eye out for it, but it’s easy to make a typo.

I think an optional result payload would be usefull

alternately just adding debug output for invalid numbers rather than failing silently.