Unable to get Kanarra Technologies Example to show device data on dashboard/details pages

Hi, I’m having trouble figuring out how to get the Kanarra Technologies Demo App device-details page to load devices & associated device data properly (Device Groups are missing on the left after logging in and tried creating a dashboard block and was unable to get the block to load any data from the referenced device). We are able to login via our application URL but things still appear to be misconfigured on our end (such as the device-details page).

It appears that there are additional steps that I missed to link group/device associations but I haven’t been able to figure out how to get any data to show yet (reviewed documentation and The Deeper Dive Webinar Series: Nested Experience Groups).

I’d really appreciate any help me on troubleshooting components that may be missing/misconfigured that would cause this type of issue. Also, it’d help to know which resources/configurations are missing from the Kanarra GitHub repo that need to be completed manually in order to get the app to display/operate like the the live version of the Example Losant Application - Kanarra Technologies which can be accessed at this link

Here is an overview of steps that I’ve performed so far
I created a new application (/applications/:5e1a1cda0f3ff900063a232e) using the standard experience templates and then manually created and uploaded all of the following files based on the Kanarra Technologies Example Application GitHub repo files:
:heavy_check_mark: ./experience and ./files
:heavy_check_mark: ./experience/workflows
:heavy_check_mark: ./experience/endpoints.json
:heavy_check_mark: ./experiences/groups.json
:heavy_check_mark: ./devices/generator.recipe
:heavy_check_mark: ./data-tables: contains CSV files that contain the required device data.
:heavy_check_mark: ./globals.json:

I also imported the devices.csv into the Devices section within the Losant application.

I’ve tried assigning a device to its group (created using the hierarchy included in the github file named groups.json).

Resource ID for our application

I’ve also attached screenshots for reference as well.

Thanks! :slight_smile:!

Hi @Cole_Hazenfield,

I am looking further into this to see if I can locate an obvious misconfiguration or missing components that may be causing an issue. I will follow up shortly with more information. :smile:

I also wanted to let you know what we are reconfiguring the Github repo to work with the new application import/export feature. I will also let you know when the repository has been updated.


Hi @Cole_Hazenfield,

I have attached an export of the Kanarra application below, and details on how to import an application can be found here.

export-kanarraDigital.zip (1.6 MB)


Hi @JuliaKempf
Thanks for your answers Julia :smile:
I just uploaded the export of the Kanarra application that you attached using the new application import feature and it worked great.

It appears that things are now properly configured since I can now see devices displayed on the device-details page, however whenever I click into a device’s Generator Details page all of the blocks show “n/a” or “No Data to Display”.

I noticed that the documentation for the new application import/export feature states that when exporting a few resources are excluded from exports (such as device state data and API Tokens). Would this be the reason why I am not seeing any state data for the devices (see screenshot below)?

And I’m guessing the reason why the Device Locations Map is blank when selecting all groups is due to me needing to upload my own Google Maps API token? (See screenshot below for comparison between Kanarra Demo Example and the imported application)

Resource ID for new uploaded application

Thanks again!

Hi @Cole_Hazenfield,

That is correct! Within the application, there is a workflow named Simulate Devices, which can be enabled to simulate device data and report state every 5 minutes. After state data is reported, the blocks should resolve to the correct view. The GPS Block does not currently require an API Token, so it should also display after enabling the workflow, as it simulates locations for the devices.

Let me know if you have any further questions :smile:


You were correct, it’s now working after enabling Simulate Devices. I will mark this topic/question as solved :smile:


1 Like