[Solved] Unable pick deviceid explicitly in edge workflow - Urgent


For some reason this afternoon around GMT+8 (15:00) this afternoon
I am unable to pick an edge device - device id in the set device state node.

The devices exists and is currently running a workflow, but I can’t edit the existing workflow as no devices are selectable and unable to create/save new workflows due to the same issue

Sorry this is a bit urgent as I need to modify agents that are currently deployed .


Further to this, other projects are exhibiting the same issue.

In another project the only device I can pick is a peripheral and not the Edge device.

We’ve reverted the change, so you can select Edge Compute Devices again. The change we made was to limit the device selector to just peripheral devices, since people were choosing standalone device types, which was causing expected behavior and confusion. Edge Devices work very similar to gateways in terms of our security model, which means they can’t report state for standalone devices. Since all devices show up in the selector, our users were assuming they could choose a standalone device and it would work.

Our recommended best practice is to use the payload path option to select “yourself” as the device. Since all triggers on Edge Workflows include the current device ID on the payload, you can reference that when you need to do things on behalf of the currently running device. The payload path is just deviceId. This allows you to deploy the same workflow to any number of Edge Compute devices and each one will reference their unique ID when running the actual workflow.

Based on your feedback, it’s definitely not intuitive to use the payload path to do this, so we reverted that change. We still want to be more helpful in the UX when choosing devices, but there’s a better, more intuitive way we can approach it.

Hi Thanks for the update Brandon.

I thought I could have set the deviceId in the workflow, but as I wasn;t sure what the root cause of the problem was, I was reluctant to udpate the running workflow.