Http Trigger node not triggered


I want to get my post data from Edge .Below I have listed my Configuration

out = ‘/data/losant-edge-agent-log.log’
level = ‘verbose’

id = ‘5d3c022c1c0faa0007333061’
key = ‘8f1ba5d7-e981-4094-b8fd-f6a92f08055e’
secret = ‘889e4c533aab95b719cXXXXXXXXe’

path = ‘/data/losant-edge-agent-store.db’


If webserver should be enabled - EnvVar: WEBSERVER_ENABLED

enabled = true

Port to run webserver on - EnvVar: WEBSERVER_PORT

port = 8080

Address to run webserver on - EnvVar: WEBSERVER_ADDRESS

address = ‘’

2.Web Page Screen Shot

3.POST Request from POSTMAN

4.Response for the request in POSTMAN

5.Edge work flow

according to the above steps
I sent the post request and I have configured the webserver PORT in the config.toml file
But my Edge Workflow not triggered.

and this is my docker command
"sudo docker run -d --restart always --name docs-agent12 \

-v /var/lib/losant-edge-agent/data:/data
-v /var/lib/losant-edge-agent/config.toml:/etc/losant/losant-edge-agent-config.toml

Kindly let me know anything i have missed or i have to do smething.

Sivasankari S

Hi @sivasankari_s,

The Edge Workflow is not being triggered as you have not explicitly exposed the web server port in your docker command. Note -p below:

docker run -d --restart always --name docs-agent \
  -v /var/lib/losant-edge-agent/data:/data \
  -v /var/lib/losant-edge-agent/config.toml:/etc/losant/losant-edge-agent-config.toml \
  -p 8080:8080 \

Documentation for connecting a container to a network can be found here.


Hi julia,
Thank you very much for your prompt reply.
I did the docker command what you mentioned.
please find my screenshots and suggest me what i missed because http trigger node not triggerd.

step 1
step 2
step 3:

step 4:

according to the above steps i try to post some data from postman to this
when I sent the data to the above url the edge work flow has to trigger.But http trigger node not trigger.
I got “could not get any response” message in postman.

please let me know the steps for the above requirement.

Sivasankari S

Hi @sivasankari_s,

I would recommend not changing the default web server address, and using http://localhost instead. Then testing again with Postman to see if a response comes through.


Hi julia ,
Thank you very much for your reply.
I did following steps for http post in edge workflow but workflow not triggered.please let me know
if i missed anything.

Step 1:
step 2:

step 3:
step 4:

in the above steps I did for Posting data through POSTMAN but edgeworkflow not Triggerd.
I have tried instead of localhost in Config.toml file.
and I have tried wifi ip in config.toml file but workflow not triggerd.

Thanks ,
Sivasankari S