Domain Name Assignment with GoDaddy

experience
#1

Hi! I would like to request some help with a proper assignment of my 2nd level domain name (myname.domain) on GoDaddy to Losant slug. I tried a few setting variations using Losant Help Doc, but didn’t succeed. This is how my current GoDaddy ManageDNS Page looks like:

Currently my domain name is irresponsive if I go to “myname.domain”. Losant main website opens up if I go “www.myname.domain” Thank you

#2

Hello @Alexander_Kondrov!

I will look into this and get back to you soon with steps toward a solution. :grinning:

Thanks,
Julia

1 Like
#3

Good afternoon @Alexander_Kondrov,

I looked into this and have some items for debugging further.

I will be updating our documentation on this to make it more clear for future users: the reason you might be seeing the Losant home page arise under the “www.myname.domain” URL is if your domain configuration in Losant does not include “www.” If you have “myname.domain” as your domain, it will not expect the “www” prefix so it must be specified.

The second problem is not well documented, and I will be creating some content for it: root domains need an A record (as opposed to CNAME) to our IP address. There is documentation by GoDaddy here on adding an A record. Losant’s IP address is 146.148.110.247.

Let me know how I can help further! :grinning:
Julia

1 Like
#4

Hi Julia,

Thank you for the prompt response. I added WWW to “mydomain.domain” and the link “www.mydomain.domain” started to work properly. At the same time “mydomain.domain” still does not work. I will add A record with Losant’s IP to see if it helps

1 Like
#5

That’s how I added A record:

I will wait 24 h for changes to take effect and will check it again.

#6

Julia, GoDaddy applied changes and now “mydomain.domain” redirects to www.losant.com. “www.mydomain.domain” works properly as I mentioned earlier. Could you help me with the issue of accessing website with a name typed without “www”? Thank you in advance.

#7

Hello @Alexander_Kondrov,

To remedy this, you have two options. The first is to create an additional Experience Domain in Losant without the “www.” prefix, giving you two Losant Experience Domains, “www.mydomain.domain” and “mydomain.domain”. The second option is to redirect within GoDaddy, if they allow it. I have not worked much with them myself on domain assignments, but if they have the redirect functionality, you would redirect someone heading to “www.mydomain.domain” to “my domain.domain,” or vice versa. Both of these options should solve being redirected to the Losant homepage.

Let me know how else I can help, or if this does not solve the redirect!
Julia

#8

Julia, overall I think I made my domain name with and w/o “www” working with Losant planform slug. FYI, there is seems to be no need to use www.losant.com IP address/ create A Record in DNS management. A record is relevant only if Losant provides an IP address directly associated with a full slug address.

1 Like