Data Table not Updating with a new Row

workflow
#1

Hi,I am trying to get my data table to update.

So far I have a working webhook with data shown in the data explorer. The payload does not have a TableID. My payload has only:
(root)
“data”:

    • “analoginput1”:xxxx
    • “analoginput2”:xxxx
    • “analoginput3”:xxxx
    • “analoginput4”:xxxx
    • “analoginput5”:xxxx
    • “analoginput6”:xxxx
    • “analoginput7”:xxxx
    • “analoginput8”:xxxx
    • “analoginput9”:xxxx
  • “time”:1554084147939

The following separate work flows were set up (tried having both of the work flows under one work flow as well):
Web hook–> Webhook Reply–>Device State
Virtual Button–> Table Insert Row–> Debug

I also tried these workflows:
Endpoint–>Mutate–>Table Insert Row–> Webhook Reply
Device State–>Table Insert Row–>Debug

Table Insert Row is set up with a Data Table ID Template that I created in Data Source>Data Table with an arbitrary data table name (scroll down menu item) and arbitrary table column names (both set under the Data Table Dialog).

The Data Table set up as follows:
Table Columns names are arbitrarily named
Table Data Column type are set as Number (tried strings as well)
Constraint set to: Required (Tried unique as well)

I can see that under data explorer data is being populated but I can not get the Data Table to populate with new rows (0).

Appreciate you showing me what I must be missing here.

#2

Hi @tirosh_gutte,

I believe I see what could be the problem, but let me know if this does not solve it!

It sounds as though you are missing one piece from your Table: Insert Rows node. The column template and value template must also be populated to insert something into your data table. For example, it would be configured like so:

If I have a data table called “Working Table” that holds a first and last name, I will have to specify where they are on my payload to get them into a data table.

Hopefully this helps,
Julia

#3

Thank you for your quick reply. I believe your suggestion was completed in the setup. Please review:

Under Table:Insert Rows
I have the Data Table ID Template set on the following data table name: Test Data Table

I also tried this:

The above table (Test Data Table) was set up in:
Data sources>Data Tables>Test data Table

Data is not populating in the data table. Please assist.

#4

Hi @tirosh_gutte,

That screenshot I uploaded seems to be getting cut off, it can be expanded if you click on it. Here is a better screenshot of what I was trying to show :smile:

In this you can see I have set values “First” and “Last” to where that value is on the payload.

Thanks,
Julia

#5

Hi Julia
Thank you for the Fast Reply

my payload is as follows:

image

I think I added the first and last item as per your instructions

Still no data updated in the Data Table

Please assist

#6

Hello @tirosh_gutte,

To debug further, could you include a screenshot of the workflow with the payload? The Table: Insert Rows Node should be in the same workflow that outputs the attached payload.

Thanks! :smiley:
Julia

#7

Let me know if you need additional screenshots
Thank you

#8

Hi @tirosh_gutte,

I would recommend setting up your workflow like so:

The reason you were not getting anything into your Data Table is because your Virtual Button workflow does not have access to those values. Since they are two separate workflows, they have two separate payloads, so those analog values would have been inaccessible. Setting up like the above workflow will allow you to access those analog values and put the data into your table.

Let me know how else I can help!
Julia

#9

HI Julia, I have set the workflow as you indicated:


… still no data is populating in to the data table
Thank you for your help

#10

Hi @tirosh_gutte,

I took a look at your Data Table and it looks as though it is populating, but only populating the analoginput1 value as seen here:

Within your workflow, however, you are setting analoginput1 and analoginput8, but you will need to also set analoginput2, analoginput3, and so on. I have not watched the payload fire myself, but it could be possible nothing is coming through for analoginput8 or the payload path could also be incorrect. You will, however, need to set your Table: Insert Rows for each analog input if you want the entire table to be populated:


Each Value Template will need to point to where the analoginput value is on the payload.

Thanks,
Julia

#11

Understood, Thank you
You Solved It !