[Solved] Peripheral device defined, and has correct properties but data not stored

#1

Hi

We have a device (Peripheral) attached to a gateway. Data is being sent by MQTT and we can see it in the connection log.

Device BLACKHAM GATEWAY (00000000d32fee9e) reported the state of Device 550781 (Blackham Pump 1)
MQTT  losant/58855ed560781XXXX4fa88/state
Wed Feb 22 2017 10:21:47 GMT+08:00
One or more of your payload properties was rejected.
A provided attribute is not defined on the device, or the data type is incorrect.
Received Payload
(root){} 2 keys
  "data":{} 5 keys
    "count":8
    "timestamp":"2016-02-22T10:21:29.977182+08:00"
    "utctime":"2016-02-22T02:21:29Z"
    "RPM":1649
    "empty":false
  "time":"2016-02-22T02:21:29.000"

RPM is a correctly defined property and isn’t being rejected however no data is being stored against this device.

0 Likes

#2

I have tried deleting the device and re-adding.

The data received is being sent to workflows, but not being stored.

0 Likes

#3

Ok, found it.

Totally missed the fact that the clock was wrong. (Out by 1 year).
For some reason the NTP service (was running but hadn’t set the time).
Restarting ntp solved the issue.

Sorry to bother you.

T

0 Likes

#4

No worries! Glad it got figured out. It would make a good feature to display a warning in the application log if the time is more than some reasonable time in the past.

0 Likes

#5

That would have saved me some time. For some reason the source timestamp was the same date but one year out, so correct day and month, and to be honest am still no used to seeing 2017 :wink:

T

0 Likes

#6

This kind of problem should be much easier to see now - as part of some updates released today, the application log will now display warnings if the timestamp of the reported data is more than a week in the past or is more than a few minutes into the future. So if it happens again, hopefully it will be obvious what is going on!

0 Likes