[Solved] Not able to view Device states sent with time

#1

Hi there,

I am sending device state with a time. But I am not able to visualize this device state in any of dashboard blocks.
But I can see in communication logs that my mqtt publish packet is recieved and correct.

I have also attached a file. Please let me know if I am doing anything wrong.

Thanks

#2

See attached. I logged into your account and am able to visualize the data point you reference in your screenshot if I use either the data explorer or the dashboard time picker to go back to the time when the state report occurred. (Note you and I are in different time zones, hence the hour discrepency.)

Dashboard blocks continually update to only show data for the last x minutes / hours / days worth of content, so in your case, once 60 minutes passes from your last state report, you would no longer see that data in the time series graph and the data table.

Please let me know if I understood the problem correctly and if there’s anything else I can do to clarify the dashboard block functionality.

#3

Hello Dylan,

Thanks for the help.

This time I cleared all data and then published few packets. I can see all the data in data explorer.
I published two packets with time and without time. One is published according to my time (GMT +5:30) and other is published ahead of the time.

Shouldn’t this be back in time? And can I sync this time discrepancy somehow?

#4

Hey Dylan,

I understood the problem. As I am publishing to my current time it publishes data to few hours ahead in time.

Can you guys remove this time discrepancy in paid version? Please let me know.

Thanks,
Ankur

#5

Ankur, as I understand it you are reporting a timestamp along with your data, hence the discrepency. Can you post an example here of the time format you are using when reporting time with your device state?

#6

Dylan, I am sending time in format shown below,
{
“time”: {"$date":“2016-15-11T12:40:00.256Z”},
“data”: {“PROCESS-VAL”: 285,“SET-VAL”: 1100}
}

I want this packet to be published to my time. 12:40:00 PM (GMT +5:30)

Can this happen?

#7

I see one big issue here: your date format is in YYYY-DD-MM (year-day-month). Per our documentation, the time should be in an ISO Date format, which is YYYY-MM-DD (year-month-day).

In the event that an invalid time is provided, we default to “now”, which I believe is what’s happening in your case. Please try changing your date format when publishing and let us know if that resolves your issue.

#8

I am sorry, I am sending time in format shown below only,
(i.e. YYYY-MM-DD (year-month-day))
{
“time”: {"$date":“2016-11-15T09:54:00.256Z”},
“data”: {“PROCESS-VAL”: 285,“SET-VAL”: 1100}
}

I think time provided in this date is considered as your time and hence state is published at 03:20:00 PM (GMT +5:30) my time.
I want it to be published at 9:54:00 AM my time.

#9

If you want it published at 09:54:00 AM your time, and you are 5.5 hours ahead of GMT, send your date string as “2016-11-15T09:54:00+05:30”. The “Z” you’re adding at the end indicates that the time should be considered UTC (aka GMT). You need to provide the offset as I’ve done in the example above.

More info here, in the Times > Time Zone Designators section.

#10

Yes it worked.
Thank you so much for your help.:smiley:

Regards,
Ankur