OPCUA Trigger does not captures timestamp value from kepware opc server

Configured Kepware OPC server as opcua trigger function with losant edge agent, when reading the data, it only returns tag name and value, not time stamp, as shown below.

  1. How do I get OPCUA data with a timestamp (from the OPCUA server itself)?


“data”: {
“identifier”: “s=Equipment.machine.Global_IOT.oventemerpature”,
“namespace”: “2”,
“value”: 22.5

2.Is there any option available to configure OPCUA trigger settings via environment variables (/etc/losant/losant-edge-agent-config.toml) ??

  1. It looks like currently we are not including the timestamp value in the OPC UA Trigger’s workflow payload; I will file a ticket about getting that added.
  2. No, trigger settings can only be provided inline in the trigger itself or within the agent config file as described in our documentation.

Just wanted to follow up on this - with last week’s platform update, it is now possible to get the Timestamp value when using the OPC UA Trigger.

Two caveats:

  1. Your device must be running GEA version 1.43.3 or higher.
  2. The Timestamp property is only available when using a named configuration for the OPC UA Trigger.
1 Like