No Modulus error on SSL setup

Hi Losant team!

I am trying to add SSL to a domain setup on my application. I followed the steps for using Let’s Encrypt. I have verified the certificate match at sslshopper (from a prior forum post). I keep getting a “no modulus” error on attempting to save.

I have tried this for 2 domains. One hosted with GoDaddy and one with NameCheap. I tried the NameCheap domain after reviewing some challenges with Let’s Encrypt and GoDaddy. Both produce the same error however.

Could this be the issue?

If so I will make a ticket to update the Let’s Encrypt guide with this new information.

Thank you Dylan! Yes - it was certainly related. Re-running the command in the Let’s Encrypt guide with --key-type rsa added, provided an opportunity to update the cert. The updated private key was then available in the noted directory.

I confirmed the Let’s Encrypt SSL works on both hosting providers (NameCheap and GoDaddy) with this update.

The new command should read:

docker run -it --rm --name certbot \
  -v "$PWD/my-ssl-certificates:/etc/letsencrypt" \
  -v "$PWD/my-ssl-certificates:/var/lib/letsencrypt" \
  certbot/certbot certonly --manual --preferred-challenges dns --key-type rsa

Thanks for the details! I’m filing a ticket now to get that updated in our next documentation update.