EEA - WASM compilation error

Hi there,
I’m successfully using the EEA on a few devices and I have deployed many versions of my embedded workflow until this happened (Device Deployment Logs):
image
I don’t think the problem comes from the embedded workflow as I only did minor changes and tried to restore previous versions without success.
Could this be a problem on the device or on the deployment process?

Note that the device works fine with the previous embedded workflow.
Cheers
Jules

Hey @Jules_Huguenin,

Our error tracking did catch your error and our engineers are investigating. We’ll keep you updated as we learn more and hopefully have a resolution for you as soon as possible.

I can replicate the problem with two scenarios:

1 - Embedded workflow, I had a cascade of conditional nodes (4X, a switch node would have been great but not available with the embedded workflows), and once I removed them it worked.
I can’t see what was wrong with those nodes though.

2 - When I try to deploy more than one workflow

Thanks for the feedback @Jules_Huguenin. Can you attach a copy of the workflow you are running into problems with so we can verify the fix we have on our staging environment will solve your issue?

We also created a feature request for the Switch Node in embedded workflows based on your feedback.

@Jules_Huguenin just letting you know we did fix the compilation error you ran into, so you should be able to build that workflow bundle now. We also have a feature request in for the Switch Node in embedded workflows.

Thanks @Dylan_Schuster, sorry I couldn’t replicate the workflow with the error as all my devices are in production.
I’ll make sure to make a copy of it if it happens again next time I work on it.
Thanks for the switch feature request!