Broken link using the Sendgrid node

Hi there,
I’ve been using the Sendgrid node to send email alerts and recently I’ve noticed that the URLs in the links are broken.
I have made a test workflow to replicate the problem:


And here is what the link looks like in the email:

I’m not too sure what happens here?
Cheers
Jules

What happens when you actually click the link? Are you redirected to the expected page or are you dropped on a 404 somewhere? If the latter, can you provide the link that the browser ultimately resolves to?

My theory is that this is just Sendgrid’s Click Tracking feature; they replace the href of all <a> tags in your emails with something pointing back to their servers so that the traffic hits them first (where the click is tracked) and then the user is forwarded on to the actual URL. This is pretty common for email delivery services.

Hi @Dylan_Schuster, thanks for your answer, the actual link dropped me on a 404 on our marketing website.
Below is the transformed link:
http://url2451.unknotsolutions.com/ls/click?upn=-2B-2FEIBf-2BG4cWzvH5O481cheZ5QCrLGqZov-2BNu5RQEz1DnpFOVM3BWhJKDom1nlEyMnpljtEcmnNojecisZq-2FQ-2Fqd5-2Bjvl8jmaUmbAwLIj-2BTI-3DmF-K_3TDZvkpUOLy7dHC4WdlkqqLIs-2FRQDXAAlwyn8xpYKGc1qbGtXTZOiJfs31YrTfJT-2BjEIwj9KW131GPO-2FaukqxCuvL4LzijB94YeRjkBGTK3mTA547Qy4AIlLcVxkGBYvmWZEHmvoaCsxkqGlaQcrBqSziMlv7dV35heXvXrj3iVTUUk7NXOFgluFedehwAX9Ns-2B4wqw6FXKeYo8g0-2FUtW5qfTm3Z1L2pMp7A51UdHeA-3D

I’ve visited the link five times now and have gotten three different results:

  • 525 Error (SSL handshake failed). Screenshot attached. (happened twice)
  • Since the link is http, I changed the protocol to https and visited that and got a page similar to the 525 page but for a timeout instead.
  • Your marketing site’s 404 page as you stated.

I still think the issue is somewhere in your SendGrid configuration; Losant is not changing the email body you submit to SendGrid.

Not having access to your SendGrid account, the next thing I would try is disabling tracking for your link. From their documentation:

Click tracking can be turned off for individual links by including the clicktracking=off attribute inside the anchor of an HTML link before the href . For example, <a clicktracking=off href="http://example.com">link text</a> would not be tracked.

If SendGrid does not replace your URL with the one you’re getting in your inbox with that attribute in place, then that would be the smoking gun that the issue is in their click tracking / your domain configuration.