"Time at value" aggregation doesnt work

Hello Losant Team!

The configuration of my gauge:

To consider:

  • WaterOn is a boolean variable and contain data. I know this because i saw it in the “Data Explorer”
  • The context variable contain a default value that is a ID of a device.
  • In “match value” i use 1,0,true,false but always get n/a

Any idea?
Thanks :slight_smile:

As a quick test, I attempted to reproduce your configuration and did not experience any issues:

Here’s my attribute:

One thing I can’t see in your screenshot is the duration. The default value for this block is “Last received data point”, which does not work for the “Time at Value” (TaV) aggregation. TaV will calculate the amount of time an attribute has been equal to the provided value over the provided duration.

1 Like

Another thing to verify is that the device exists. In my testing, an invalid duration results in an error, not “n/a” like you’re experiencing. However, if I delete the device that I previously configured as the default context variable value, I do receive the “n/a”.

Open the dashboard settings and select the Context tab. Verify that the device you have selected as the default value for devId still exists.

1 Like

Thanks for the reply Brandon. At least i know that the configuration is correct. If i found the solution i will write here.

I found the solution. Basically when i added the gauge i was testing with a test device. Now i use the real devices and i forgot that the variable name changed. Sorry and Thanks