Table Get Rows node not returning data although 'Match' is OK

Greetings. Not sure what’s going on here but one of my workflows suddenly does not return matching data from a Table Get Rows query, although the filter ‘matches’ with the table entry, which exists and it is correct:

Any suggs as to what might be happening? Thanks :red_circle:

Hey @Jose_Cruz,

I’d really like to have some more information. How often does this workflow run? Can you confirm that there are records in the data table that have that field and value? Would you be able to provide a more concise timeframe around “all of a sudden”? Did was it working earlier today and is now not working?

Any additional information around this would be very helpful.

Thank you,

@Heath , thank you. I was able to narrow this to just (1) device; the information is correct in the data table, checked it various times, but for some reason the Table Get Rows query doesn’t return any information - tried it with other sensors and it does correctly. No changes have been made to workflow/table in a long time, so that’s why this is a sort of mystery that just came up yesterday…

I will submit a formal support ticket with clearer information soon, thank you! :red_circle:

@Heath : mystery solved! Thanks to @Dylan_Schuster for pointing out that there was a ‘subtle’ [space] character/text at the end of the sensEUI that we did not see; totally a slip, mistake from our part! Thanks both for the help on this issue! All is working now, :red_circle: