[Solved] Atlas MongoDB connection


#1

Hi good morning.
I am trying to connect to Atlas MongoDB M0 with the following URI (provided by mongodb connection string )
mongodb://cluster0-shard-00-00-8zgqm.mongodb.net:27017,cluster0-shard-00-01-8zgqm.mongodb.net:27017,cluster0-shard-00-02-8zgqm.mongodb.net:27017/test?replicaSet=Cluster0-shard-0 --authenticationDatabase admin --ssl --username --password

It works perfectly on Ubuntu 17.04 but I receive this error message in my Workflow.

MongoError
connection 344 to cluster0-shard-00-01-8zgqm.mongodb.net:27017 closed

I dont know how to move forward with it. Cannot make it work. Any suggestion or hint, please. Thanks a lot


#2

The URI to connect through a shell is slightly different than the URI needed to connect from a remote application, or in this case a Losant workflow. Try the following URI in your workflow and let us know how it goes:

mongodb://<USERNAME>:<PASSWORD>@cluster0-shard-00-00-8zgqm.mongodb.net:27017,cluster0-shard-00-01-8zgqm.mongodb.net:27017,cluster0-shard-00-02-8zgqm.mongodb.net:27017/<DATABASE>?ssl=true&replicaSet=Cluster0-shard-0&authSource=admin

Replace <USERNAME>, <PASSWORD>, and <DATABASE> with your information of course.


#3

Solved!. Awesome. It worked !!!, right away. Thanks so much.