Nothing showing up on the Serial monitor


#1

We created the moisture sensor kit and followed instructions. The firmware did download on the sensor but we do not see anything on the serial monitor


#2

The first thing to check is that the baud rate on the serial monitor is set to 115200.


#3

Yes, It is. What else can we check?


#4

You can also try closing and re-opening the Serial Monitor. When you do attempt to open it, are you seeing any error messages in the Arduino IDE’s output? Something like the following?


#5

This is what we see


#6

It is strange that it flashes successfully, but then nothing shows up in the serial monitor. Please try pressing the small “RST” button on the NodeMCU while the serial monitor is open. That will reset the board.


#7

I have this display problem so i followed the steps in this discussion but i still have this issue. At the beggining, I used the latest version of Arduino IDE, due to these errors I installed Arduino IDE 1.8.0. Now I can see the first message on the monitor but there are no other messages (connected, open door, close door)

I use the door sensor kit (following the tutorial)
What else can we check?


#8

I see the same first line after pressing the reset button

What else can we check?


#9

The first line of unreadable characters is expected. Those are printed by the ESP as part of the boot process. It should then immediately start printing other stuff. I’ll provide a simpler firmware shortly just to test that the boards are working at all.


#10

Sounds good. Thank you.


#11

Do we need to upload the program from the computer each time we connect the sensor with USB or should it automatically recognize and start running? We currently upload the program each time.


#12

You only ever have to upload it once. Every time the board is powered again, the last uploaded program will start running again.


#13

Thanks, yes it sent the gibberish again after hitting the RST button without re-uploading the code


#14

Here is a basic sketch that will print “Hello!” to every second. Please try flashing this to the device to see if you’re able to get any serial communication at all.

void setup() {
  Serial.begin(115200);
  while(!Serial) { delay(100); }
}

void loop() {
  Serial.println("Hello!");
  delay(1000);
}

Another think to double check is that the “Flash Mode” is set to “QIO” and not “DIO”.


#15

I used the basic sketch with Generic ESP8266 module (2.3.0 and 2.4.0) but I have the same issue. I can’t get any serial communication at all (after the first line).


I pressed the small “RST” button many times. It duplicates the first line (no Hello word).

What do you think about programmer? You can check the picture.


#16

You have a replacement NodeMCU on its way. In the mean time, we’ll continue to do some testing to see if we’re able to reproduce the issue here.


#17

Thank you for the follow up.


#18

First of all, thank you for your help.
There are two good news and one bad news.

For the good news, I started with the basic application ‘Hello’ and it works properly. After that, I used the same configuration for the door sensor kit and I succeeded to receive data on my DASHBOARDS losant (I tried also alert email and it works properly)


For the bad news is that the serial monitor does not work on the application of the door sensor kit despite that I manage to receive the data on the cloud.


#19

We replaced the board and now get an error:

Arduino: 1.8.5 (Windows 7), Board: “Arduino Yún”

C:\Users\mehtb1\Downloads\losant-kit-moisture-master\losant-kit-moisture-master\losant-kit-moisture\losant-kit-moisture.ino:12:25: fatal error: ESP8266WiFi.h: No such file or directory

#include <ESP8266WiFi.h>

                     ^

compilation terminated.

exit status 1
Error compiling for board Arduino Yún.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.


#20

Looks like the board is not selected correctly in the Arduino IDE. Please make sure the board is set to “Generic ESP8266 Module”. You’ll probably also want to re-check all of the other settings and confirm they are still correct as well.