Issue on MQTT connection between Edge Agent and Losant

Hey guys,

I have an Edge Agent installed in my raspberry pi, and I’m working on a Workflow that will get data from a serial port in the pi and send it to Losant.
I was able to send the data up to Losant using the “Send State” node. But it fails when I try to use the MQTT node.
I set up a simple workflow in my agent that just send a message to the Losant Broker. And added a workflow in Losant that is triggered on message arrival in the given topic, but when I send the message nothing happens on the Losant side.

This is how the Edge Workflow looks like:

And this is how the Losant Workflow looks like:

When I send a message from the Edge, a debug message is printed in the Edge WF but nothing happens in the Losant WF.

Is there something that I’m missing in my Edge Agent configuration that I need to do in order to send messages to the Losant Broker? (I’ve also tried sending messages to the Local Broker within the Edge Agent and it works fine)

Thanks in advance

Hey @Nicolas_Mascardi,

It looks like you have a custom topic configured edgeAgent/logs in your MQTT nodes. With the access key and secret you have configured have you enabled access to all MQTT topics?

By default access keys only allow access to the device-specific topics (e.g. state and commands) for every device you have allowed. So you’ll need to configure access to those custom topics you have defined (

This is a great question, and its not uncommon, we’ve had a few forum threads around this topic that may help guide you as well:

Let me know if this gets you on the right path!


1 Like

Excellent! I wasn’t aware of the “enable additional topics” feature. It’s working now thanks!