Issue connect to losant with IoT Dev Kit


#1

Hi

I am playing with the IoT Dev Kits on the ESP8266.

Well everything was working fine a few days ago, but today the kit isn’t connecting.

image

I am using the code from here:

https://docs.losant.com/getting-started/losant-iot-dev-kits/builder-kit/#8-workshop-3-temperature-sensor

I tried to re-upload the code with a new key, still not connecting.

is there an issue with the MQTT broker?


#2

Hi Tom, we’re not having any broker issues on our end. When you attempt to connect, do you see any activity in your application’s communication log?

Not that I think this is the issue you’re having, but you can also test your connection credentials using our device simulator. Use the same key and secret that is on your device to connect. Behind the scenes the simulator is connecting to the broker as if it were a device just like you’re doing on the ESP8266.


#3

Hi

well it is working now.

I disconnected the unit from the breadboard, and tried a different code set, and it connected.

now I reconnected it to the breadboard and returned to the other code, and it is also working.

Not sure what the issue was, these $3 Chinese ESP8266 are not very stable, so who knows…