"Illegal instruction" after restarting the docker container

Hi there
Hope you are well.

I am running the edge workflow in my gateway and it is working properly.
By the way, if I restart the Losant docker container, it does not start properly and I see the below error.

I executed “docker ps” command in the terminal at this time, and it looks like the docker container is running, but I see the error output and the device is not connected to the Losant platform.

So, if I remove the docker container and run the docker container again, it works properly.
But, it does not work properly once I restart it. It should be solved.
What’s wrong with this? Can you please help me?


Hi @Abdurahman_Hojkuric ,

Are you using Alpine GEA on a Vantron G335? If so, I recommend updating to version 1.41.1 as it contains a fix for the Alpine version on 32-bit ARM hardware, such as the G335. The image can be pulled with the following Docker command: docker pull losant/edge-agent:latest-alpine.

If you are still running into problems after updating, please share the docker run command you’re using.

Hi @Sebastian_Turner
Thank you for your update.

I will try and update you.

Hi @Sebastian_Turner
I used the latest-alpine docker image and it worked for me!
Thanks a lot!

1 Like