Edge Device Docker Failure

Hello,

I’m working on a proof of concept using our existing IoT devices ( Compulab IOT-GATE-iMX7) , but have run in to issues even getting Docker to run. After installation of Docker using the Losant guide, it fails to start.

Is anyone familiar with these devices, and have successfully gotten Docker/Losant to run on one? I think it may be a kernel issue unfortunately…

Hi @PhillipKB,

I am not familiar with these devices, but will look into them a bit further. Are you seeing any errors? And if so, could you provide a screenshot? The device is an ARM device, so you may need to pull a different image, the supported tags can be found here. You will need to add the version at the end of your command, as specifying an image losant/edge-agent without a tag, you are asking for the latest tag of the Agent. Here’s an example with latest-arm:

docker run -d --restart always --name docs-agent \
  -e 'DEVICE_ID=<your-device-id>' \
  -e 'ACCESS_KEY=<your-access-key>' \
  -e 'ACCESS_SECRET=<your-access-secret>' \
  -v /var/lib/losant-edge-agent/data:/data \
  losant/edge-agent:latest-arm

Thanks!
Julia

The problem is Docker will not even run. Yesterday I tried a different OS image that is supposed to have docker kernel support in it (Ubuntu Core), but Docker will still not run. When I try to pull the losant agent, it says it can not connect to the daemon.

localhost:~$ systemctl status snap.docker.dockerd.service
● snap.docker.dockerd.service - Service for snap application docker.dockerd
Loaded: loaded (/etc/systemd/system/snap.docker.dockerd.service; enabled; vendor preset: enabled)
Active: failed (Result: start-limit-hit) since Fri 2019-06-14 15:39:23 UTC; 59min ago
Main PID: 3775 (code=exited, status=1/FAILURE)

localhost:~$ sudo docker pull losant/edge-agent
Using default tag: latest
Warning: failed to get default registry endpoint from daemon (Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?). Using system default: https://index.docker.io/v1/
Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?

@PhillipKB,

I did some research for you, could this be your issue:

Overall, Docker has to run properly before you can pull and run the edge agent.