Particle integration no longer receiving events

workflow
#1

I have several Photon devices generating events and up until yesterday those events were recognized by my Losant integrations. This covered two applications and three integrations and had been working flawlessly for 8 months. No changes to Losant or Particle devices or components in weeks. Just now I created a new integration and tested Dylan Schuster ‘particle-vitals’ but even that simple workflow fails. I also generated a new Particle access token with the same result. I can see all of the devices publishing events in the Particle console so the data is there just not recognized. Next steps?

#2

I should add all of my integrations show they are in the disconnected state. Until yesterday they showed connected. They will not reconnect. All of the Photons are on 1.0.1 dev OS.

#3

@Ed_Stubbs I can verify that it is not a system-wide issue, our own particle devices are continuing to report data correctly through Losant integrations at the moment. Could you let me know what kind of error/disconnect messages are displayed on your integrations?

#4

Thank you for the prompt response. Screen shot attached.

#5

It looks like Particle’s API is rate limiting connections, preventing us from establishing the streaming connections for some integrations. We have worked around this for the moment, and have also added additional information in the interface (if you hover over the disconnected message, there will be a tool tip with more details). We will also be investigating how we can work with Particle to keep this from happening in the long term.

1 Like
#6

Thank you works perfect. Losant has been an excellent IoT platform during my testing.