Mutate choosing unexpected field

Why does my mutate function seem to choose the “time_ns” value to do the date conversion? I want it to chose the “storedLastTimeDate2” value.

I chose SET A NEW VALUE and:
{{formatDate working.storedFirstTime_ns.convert ‘ddd D MMM YYYY hh:mm:ss a’}}

I expected to see:
Thu 9 Jan 2020 03:01:21 AM (I believe this corresponds to 1578538881000)

but instead see:
Thu 9 Jan 2020 03:04:50 AM (I believe this corresponds to 1578539090000)

It’s a fairly complicated workflow, not sure how to attach more.

Hi @Bryan_Chase,

Your timestamp is located on your payload at working.storedFirstTime_ns, but you are referencing working.storedFirstTime_ns.convert is this intentional or is there a value missing?


Oh I thought that was required for the syntax of formatDate. I took out the convert and it worked better. Although I had 2 rules set in a different mutate and found it worked accurately when I split them up but not when the 2 rules were together.

I think it’s working now, thanks!

1 Like