MQTT Debug Workflow no messages

Hi there,
Just started my journey with Losant so this could be a trivial issue.
I have connected the MQTT integrator to my TTN Pro account.
I can see all my devices streaming data:

But I see nothing in the Workflow:

The MQTT seems to be connected properly (green icon).

The topic is set according to standard practice

Let me know what I am doing wrong!

Screenshot for MQTT integrator:

@Paolo_Proxy I’m looking into this currently. One question: Are you able to publish a message on one of the topics in your MQTT integration? i.e. if you add a Virtual Button connected to an MQTT Output Node that is configured to publish a message on your integration and one of your topics, do you see that message come through on the TTN side?

Also, are you seeing the messages you publish appear in your application live log?

Hello, AFAIK the TTN MQTT blocks any publish operation that are not coming from their infra, in-fact I also tried with a separate python code and I can only subscribe, I can publish but I cannot see my own messages. So it will not be a good test to perform in this occasion.

The logs are empty even though my MQTT explorer is full of events.


Thanks. The next thing I would try is changing your integration to subscribe to one or more specific topics - as in, remove the wildcards for now and just enter one or more of the specific topics that the wildcard would normally resolve to. After you do that, are you seeing any activity in the workflow or the app live log?

Can I use the pound sign # to subscribe to all topics as per MQTT standards?

Per our documentation, yes, multi-level wildcards should work; have you tried one and are not still seeing messages come through?

Since we are trying to debug the connection, I still recommend adding a specific topic (free of wildcards) to the integration and seeing if messages on that topic are coming through. Once we know that’s working, then we can start expanding the integration to add those wildcards back in.

Ah TTN tricked me, the actual full wildcard was:


Where + will expand to the device id.

Glad to hear. Please let us know if you have any more questions.

P.S. Welcome to Losant!

1 Like