JWT token for password reset

I have an experience (using an assigned C-name domain name) where I have successfully implemented the forgot password feature as described here: https://docs.losant.com/guides/building-an-experience/forgot-password/

I cloned this experience and tried to implement the forgot password feature, and made sure I created a different global JWTsecret, first, but when testing this the token I receive in the email isn’t valid and I see this :image

As a FYI, the cloned experience is using a “{appid}.onlosant.com” domain

Hi Lars,

I am currently looking into this, and will follow up shortly with more information.

Thanks so much!
Julia

Hi @Lars_Andersson,

This messages appears as the result of templating within your Experience Page. To debug this problem I suggest:

  • Experience Render Log - to see the value of the context provided to your page
  • Experience Workflow Debug Log - to see the value of the payload when this page is executed.

Please let me know if you have any additional questions.

Thanks!
Julia

Looks like it fails at the conditional node labelled “Password not reset yet?”
I tried changing the node that creates the token and set it to have no expiration, but it still fails.

I noticed the forgot-password workflow in the experience that works, looks like attached image. This is different from the walkthrough and doesn’t look correct to me.

I just noticed this in the application log, so maybe that is related to my problem. Not sure how the component “successAlert” should be defined though…?
image

Never mind , I found it

<div class="alert alert-success">
  {{.}}
</div>

Fixing the missing successAlert component did not change anything.
If it’s any help, it seems that this problem is only occurs to my account, even if I’m not signed in to the Losant platform as a user and have cleared cache.
What’s so starnge is that it works in the original application just fine, but not in the cloned one.
Now that I know this, it’s not a big problem, but would be curious to find out why this is happening.