Issue with SSE Stream

I’m trying to use the SSE Stream endpoint reply but for some reason, the Device Id template field is not rendered and a message error saying “Requires selecting at least one stream.” is displayed. I guess that is not detecting the selection of the stream in the “Add Stream Source” dropdown. Can you please confirm this issue? Or am I doing something wrong? Thanks in advance!

Hello @Nicolas_Mascardi,

Thank you for bringing this to our attention!

I was able to reproduce this issue and have created a ticket with our engineering team for it. I will be sure to follow up with you as I learn more about its development.

Thank you,

@Nicolas_Mascardi if you press the little “plus” button alongside the “Device State Topic” dropdown, it will add the device selector to the interface.

FYI, the node is built like this because, in one state stream response, you have the option of returning the state streams for multiple devices and/or multiple MQTT topics. This UI allows you to choose one type at a time and include it in what will be sent in the SSE stream. As noted in your screenshot, you must include at least one device or one MQTT topic.

Please let us know if you have any other questions!

I didn’t realize there was a ‘+’ button. So sorry, thank you very much!